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All material  copyright BragIt © 2004-2012

Welcome to StockXloader—getting quotes from any stock market

1 GETTING STARTED

1.1 Documentation and Help

All documentation, including this User Guide, is available through menus or 
popup buttons. Guidance is provided by the following:

1. User Guide (online): The guide you are currently reading.

2. Read Me: System requirements, installation instructions, etcetera.

3. Release Notes: What’s new in this version, version history, any known 
“issues”.

4. FAQ (online): “Frequently Asked Questions”.

5. Support & Troubleshooting (online): Procedures for isolating the source 
of a problem you may experience.

6. Purchase License: How to purchase a License Key.

7. License Agreement: The License Agreement for using StockXloader in 
either Evaluation or Licensed mode.

8. StockXloader Website: The web site for StockXloader.

9. Tool Tips: They show up for a brief moment when you hover the mouse 
over an interface item, and provide short explanatory texts that tell you 
what the item is used for or how you accomplish a task. 

To access these items, look for the application menu StockXloader 4, the Help 
menu, and the menu button in the Welcome window and Download Con-
troller. Also, there is the Yahoo help pages that you can find in the Yahoo 
menu and in the toolbar menu button .
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1.2  Basic Usage

Ticker Lists • If you are new to StockXloader, the first time you start it, you will be 
offered an optional Sample Ticker List. You can either edit this to suit 
your needs, or you can copy and paste rows from it into a new ticker 
list. If you delete this list, you can bring up a new one by using the 
menu File > Sample Ticker List. Initially, all symbols are disabled.

• If you are upgrading from StockXloader 3, you will be offered to import 
all four ticker lists from StockXloader 3, and it will preserve your set-
tings of Last Date and the enable status.

• To open a ticker list and edit its content, just double-click on the name 
of the ticker list. The following shows the Sample Ticker List.

The Ticker List Editor • The ticker list editor supports full multiple undo! This means that you 
can undo any operation anywhere in the editor as many steps you like 
— and redo all the way back! This even works after you have down-
loaded quotes and StockXloader has updated the date/time columns — 
if you undo at that stage, it will revert the dates/times to the instant 
before you downloaded! This can be useful if you want to re-download 
for some reason.

• You can set the category of each ticker symbol, such as stock, index, 
mutual fund, future, but you can also select a number of rows and use 
the toolbar item Type to set the category for all of them. Similarly, you 
can enable/disable individual symbols, or enable/disable all selected 
rows. Disabling a row can be useful to exclude it from downloading 
without having to delete the row completely.

• Each ticker symbol can optionally be mapped to a name you prefer to 
use instead of the Yahoo symbol. The mapped name (if you have given 
one) is what will be used in the data file that will be imported into your 
application (such as ProTA or Excel). You can also give a symbol its full 
security name and/or supply a comment.

• You can sort the data on any column, or filter (search) the data. For 
instance, sorting on Last Date makes it easy to find symbols that lag, i.e 
symbols whose data is significantly older than other symbols. That indi-
cates a problem, such as the company no longer exists, has been 
renamed to a new symbol, or Yahoo has a data feed problem. In the 
example screen shot to the left, you can see below the table that Worst 
Date is June 27 whereas the Best Date is August 14. In the table you will 
find that the troublesome ticker symbol is ^GSPTSE, ie the S&P TSX 
Composite index at the Toronto exchange. Yahoo stopped getting data 
for it on June 27.



20
12

-0
8-

30
StockXloader User Guide GETTING STARTED 3 of 10
Preferences—before first download • Before you download for the first time, go to Preferences and set which 
program you want to import data into, and make yourself acquainted 
with some of the other settings.

Download • The first time you download data for a ticker list that has symbols 
whose Last Date column is empty, you are prompted to set the date 
from which you want to download. The next time, it will remember the 
last dates of quotes for every ticker symbol, so that date will be the start-
ing point for the next download.

• After StockXloader has finished downloading, it will launch the 
program you have chosen in Preferences, which will start the import of 
a file called Import.txt.

If ProTA is your choice, it will show its Universal Importer. The settings 
you did in the ProTA section of StockXloader Preferences will be com-
municated to ProTA. With the proper settings, all you need to do at this 
stage is to click the button Start Import.

• Sometimes you may wish to back the date for one or several ticker 
symbols and re-download historical data. In the ticker list document, 
you can simply double-click the Last Date column for the ticker symbol, 
which brings up a small panel where you can set the date. See the left 
picture.

Alternatively, you can select a number of rows and use the Settings 
toolbar item where you choose Set/Adjust Date, as in the following picture:
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2 THE DOWNLOAD CONTROLLER

Create a new ticker list / Delete selected ticker list
Rename selected ticker list

Preferences / Show in Finder
Various links to the Yahoo site

online help pages

Some of the enabled ticker symbols in this list had data up to the Best Date
on their last download of historical quotes, whereas other symbols only had
data up to the Worst Date

Latest price values
(delayed intraday values)

There are 34 enabled symbols in this list

Snapshots are always downloaded before historical because historical may be “richer” and more 
accurate. For instance, snapshots may lack volume whereas historical may include that, and the 
Open quote for snapshots is sometimes just the previous day’s close whereas the historical may 
have the real Open quote.

In this example, StockXloader warns that some symbols did not have any historical quotes. 
In principle, it could be because the symbols are wrong, but in this case it is simply because 
Yahoo did not carry any historical quotes for the currencies, and for ̂ GSPTSE, i.e the S&P TSX 
Composite index at the Toronto exchange, Yahoo stopped getting data for it on June 27.
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3 LICENSE KEY

Extended evaluation period If the trial period has expired, but you really need more evaluation time, e.g 
due to a long “inactive” period, you can apply for an extended evaluation 
time. The procedure for requesting such an extension is provided when you 
start StockXloader and the trial period has expired or there are only a few 
days left. You must provide at least some form of motivation, although we 
are pretty liberal and generous about extensions.

Second license key A license key is valid for one user, identified with either the login Short 
Name, which is the same as the name of the home folder, or with the full 
user name as shown in System Preferences > Users & Groups. If you buy a new com-
puter, or use more than one computer, you will normally use the same 
account name. In special rare cases, however, you may have chosen to use 
different such names on the different computers, despite you are the only 
user of StockXloader. If you really need to get a second license key, BragIt 
may offer you that if you send a mail to support @ bragit.com and provide:

*   My full name = …
*   My current license key = …
*   The licensed User Name for the current key = … . . . . . . . . . . . . . . . . . (these are case sensitive)
*   The User Name (either 'Short Name' or full name) for the new requested key = …
*   My motivation for getting an additional license key = ...

Note that the User Name (both the 'Short Name' and the full name) are case 
sensitive—Joe is not the same as joe. Naturally, BragIt can not grant you a 
new license key automatically—only if the statement of reasons is motive 
enough. Different people using StockXloader should buy their own license 
keys, unless you accept that they all use the same login account on your 
computer and they all work on the same database.
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4 GENERAL NOTES AND TIPS

Dates All dates presented by StockXloader follow your regional settings, and 
where times are presented, they are in your local time zone. Specifically, this 
means that the times of snapshots you can see in the Ticker List and in the 
Download Controller, are the last traded times as given by the Yahoo data-
base, translated into your local time zone, including any daylight saving 
time. (The times in the Yahoo database are New York times, which may 
include daylight saving time.)

Message log You can save the Message Log to a plain-text file if you want (use the File 
menu Save...). The name of the file is automatically set to a name that includes 
the current date, as in the following example: StockXloader log [2012-06-27].txt.

In the Message Log, certain warnings are highlighted in red. These warnings 
are not necessarily fatal, but worth reading.

Location of ticker lists In the Download Controller, you can access your ticker lists in Finder by 
using the toolbar menu button Extras, item Show Ticker Lists in Finder. They reside 
in: <your home>:Library:Application Support:StockXloader 4: Also temporary files are 
downloaded into a subfolder there, along with the finally converted and 
assembled file Import.txt. In Lion and Mountain Lion, the Library folder is 
hidden, but it can be accessed In Finder by: hold down the option key and 
click the Go menu choosing Library (may have other names in your 
language).

From a Ticker List, you can also access it in Finder, but you do that the stan-
dard Mac OS way, i.e hold down the command key and click the document’s 
name list.

How to reset If you delete the whole folder <your home>:Library:Application Support:StockXloader 4: 
StockXloader will automatically recreate it and any necessary files in that 
folder the next time StockXloader starts. To reset your settings in Prefer-
ences, plus the widths of windows and table column widths, window 
positions etcetera, you need to delete the Preferences file, which you can do 
as follows: 

1. Quit StockXloader, then in Finder, hold down the option key and click 
the Go menu, choosing Library (may have other names in your 
language).

2. Continue to hold the option key and double-click Preferences.

3. Delete all files starting with com.bragit.StockXloader4.plist.

4. Start StockXloader.

Renaming ticker lists You can select a ticker list in the Download Controller and use the toolbar 
button Rename. This will automatically show the file in Finder and highlight 
the name so you can change it. Actually, you can always rename your ticker 
lists in Finder any time you want (but don’t do that while you are download-
ing). When you switch back to StockXloader, it will always automatically 
refresh the list in the Download Controller!

Moving ticker lists
Optimizing start-up times

Also, you can move any ticker lists you are not interested in any longer to a 
subfolder you may want to create. This will hide them from StockXloader, 
which also will start-up faster since it does not have to read the contents of 
those files. (Very useful if you have a huge list with thousands of symbols.) 
When you want to work with an old list again, you can simply move it back 
into the StockXloader 4 folder!
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5 NOTES ON YAHOO TICKERS

Strip stock-exchange suffix Most Yahoo ticker symbols for non-US exchanges have a suffix indicating 
the stock exchange, such as 'ST' for Stockholm. StockXloader can optionally 
strip this suffix so you don’t have to see it in your destination application. To 
do that, tick Strip stock-exchange suffix at the bottom of the ticker list editor. Alter-
natively, you can map the name to whatever you like in the column Mapped.

Example: ERIC-B.ST will then translate into ERIC-B. If you only deal with 
tickers from one stock exchange (besides looking at world indexes), this 
may make the symbols more familiar and easy to read, but if you work with 
several stock exchanges, it is safer to keep the suffix.

Finding the ticker symbol To find the right ticker symbol for a certain security (share/stock, fund, 
index, future, option), use the toolbar menu and choose 
Ticker Symbol Lookup (or the shortcut equivalent Cmd-1), and then search for the 
security you are interested in. Alternatively, use the Yahoo menu. Beware 
though, that not all tickers carry historical data—as of this date, most 
futures, options, currencies and metals only have data for the current day. 
An exception, however, is EURUSD=X, which, as of this date, actually has his-
torical data, despite it’s not seen on the Yahoo web page!

Lookup selected ticker symbol To lookup the ticker symbol for the currently selected row, use 
the toolbar menu and choose Symbol Lookup of Selected Row (or the 
shortcut equivalent Cmd-2), as the picture below shows.

Close vs adjusted close The term Adjusted Close means that the Close quote has been multiplied by 
a value as a result of splits and/or dividends. The ticker list has an option 
where you can tick Use adjusted close instead of real close. This will use the Yahoo 
column 'Adj Close' instead of the actual real close. It will not affect open/
high/low quotes.

Although files for historical quotes from Yahoo do contain a column for 
adjusted close, many ticker symbols for non-US markets have not been 
adjusted at all, despite the claim and despite splits really have been per-
formed. And for tickers that actually have been adjusted, only the close is 
adjusted, which means that the open/high/low quotes remain untouched, 
which is totally unacceptable when charting these quotes! In contrast, when 
ProTA adjusts for splits, all quotes for the day are adjusted, i.e open/high/
low/close.

To avoid the risk of getting an inconsistent database of mixed Close/
Adjusted Close, depending on when you download, the safest is to use the 
real Close, leaving any necessary database adjustments to be made later (e.g 
in ProTA) under your full control. If you do this in ProTA, it will set the 
appropriate note that specifies for which dates the adjustment was executed, 
so it all becomes explicit.

You have hereby been warned, but the choice is yours. StockXloader offers 
the choice only because a fair number of customers have requested this 
feature.
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6 SPECIAL PROTA SETTINGS

Settings for the Import Format StockXloader can automatically tell ProTA which columns contain which 
fields, and what the delimiter is, and what the number format is, and ensure 
correct interpretation of dates. Also, in StockXloader Preferences you can set 
if new symbols should cause ProTA to automatically create new files (or 
show a prompt or skip), and if data for existing dates should be replaced or 
skipped, and if any errors should be logged, so you have full control over 
how new symbols and existing dates are treated.

In addition, it specifies a Settings file named StockXloader. The purpose is 
that it provides you with a method to automatically control a few other 
things that StockXloader by itself cannot control directly, namely those that 
are outside the red encirclement in Figure 1. E.g, you might want to associ-
ate a file that map tickers. However, most users will not need that, since 
StockXloader itself has the feature to map a Yahoo ticker to one that you 
prefer. The other thing you may want to control is that existing security 
names should be replaced—this way you can rename a security by chang-
ing its name in the StockXloader ticker list, and ProTA will then adapt on 
next download.

How to create a Settings File If you have no need to control the items outside the red line in Figure 1, you 
can ignore the rest of this chapter. 

You create and edit the Settings File from within ProTA. Choose Tools > 
Universal Text Importer, click Settings Database. Then, follow instructions in Figure 2.

Figure 1 This is the import window that is shown each time you import from 
StockXloader. StockXloader automatically sets all items encircled by red, whereas the other 
items are things you can control by making a settings file called StockXloader.

StockXloader controls this automatically
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Next time you import from StockXloader, your settings will be loaded auto-
matically together with those that StockXloader controls directly. The import 
window that is shown each time you import from StockXloader (Figure 1) 
will say that the Settings File is called Custom; that is simply because it starts 
with your settings StockXloader, and then control statements “modifies it” by 
setting the items encircled by red in Figure 1.

7 IMPORTING TEXTUAL TICKER LISTS

Simple import If you have a text file with ticker symbols, one line per symbol, you can 
import that into StockXloader, and after that you can edit the list as any other 
ticker list inside StockXloader. To accomplish this, do as follows:

1. Make a list of ticker symbols in a regular plain text ASCII file with one 
line per ticker symbol (but it may also use Mac OS Roman encoding or 
UTF-8). The file must have file extension ‘txt’, the line endings may be 
CR, LF or CRLF.

2. In StockXloader, choose File > New Ticker List. Name it anything you want.

3. Choose File > Import Ticker List...

4. Choose the textual ticker list and click Import.

You can also import to an existing list. To see the added symbols in the list, 
use the menu View > Sort/Unsort Table, or click the corresponding Sort/Unsort 
button in the toolbar to make it unsorted (so you can see the new rows at 
the end of the list).

Note: the choose-file panel starts in the support folder for StockXloader 3 if 
it exists, otherwise it starts in the last folder you used.

Advanced import StockXloader has an importer that can import, not only the basic ticker 
symbols, but also full import of the security type, security name and a 
comment, and even the enable status. This is used to import ticker lists from 
StockXloader 3, but it can be used generally to import ticker lists that may 
have been generated by a program. However, a note of warning:

Figure 2 This is the Settings Database in ProTA. Create a Settings File called 
StockXloader, and make your settings as desired for the items encircled by the right 
green line (StockXloader controls the other items).

Create this Settings File. Make the settings as you desire.
Create a Mapping if you wish.Must be named StockXloader.
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NOTE This feature is only provided as a convenience to those who want to have a 
programmatic way of suppling ticker lists. We do not give user support for 
this feature, so you can not mail and ask for advice on how to do, or if you 
have problems with this interface. It is provided as is. You may report bugs, 
but there is no obligation that it will be fixed beyond what is needed to 
import ticker lists from StockXloader 3.

To import a fully specified textual ticker list, you do the same as in Simple 
import, but with a file that has some more information, ordered in a specific 
way. Do as follows:

Make a list of ticker symbols in a plain text file with one line per ticker 
symbol, using any sensible text encoding, such as Western, Mac OS Roman, 
Latin 1, Windows or UTF-8 (it will attempt to guess the encoding). The file 
must have file extension ‘txt’, the line endings may be CR, LF or CRLF. Make 
each line to comply with the following rules for extracting the enable, secu-
rity types, tickers, security names and comments, in order of priority:

1. A ticker line that starts flush left with ‘#’ and is directly followed by 
either a type code or a ticker symbol will be set to disabled, provided 
that the rest of the line can be interpreted as a valid line. (Note, if there 
is a space or tab after the ‘#’, the line will be regarded as a comment and 
therefore ignored.)

2. A security type is a single character in the set [SMIFOB] (for: Stock, 
Mutual fund, Index, Futures, Option, Miscellaneous) that either starts 
flush left on the line or directly follows a ‘#’, and is thereafter directly 
followed by a colon and optionally some spaces/tabs. A security type 
may be left out, whereupon the importer will assume it is an Index if 
the ticker symbol starts with ‘^’, and it will assume it is a Mutual Fund 
if the ticker symbol is exactly 5 characters long ending with an ‘X’, and 
it will assume it is Misc (for currency/commodities) if the next-to-last 
character in the ticker symbol is ‘=’.  In all other cases, it assumes Stock.

3. A ticker is a sequence of characters in the (regex) set
[a-zA-Z0-9_-^.:=] right after the security type indication (if any), or 
after a disabling #. (A consequence of this and the above is that it must 
start flush left unless there is a security type, or it is disabled by #.) Note 
that the allowable character ‘_’ does not seem to be used by Yahoo, but 
it is included just in case Yahoo would use it in the future. Furthermore, 
the importer requires the first character to be in the set [a-zA-Z0-9^].

4. The full security name is taken after this ticker and some spaces/tabs/=  
characters, as a sequence of 0-63 of non-(tab, #, new-line). (If it is 
longer than 63 characters it will “spill” into the comment.)

5. A comment after tabs or the #-character, ignoring any white space right 
after the #-character.

ProTA can only take 63 characters as a name, and if there are more charac-
ters, the result is shown as an empty name! Therefore, it is important to limit 
the length here! May be any MacRoman name. (Note that trailing spaces are 
not stripped.)

Lines that do not comply with the above rules are simply skipped.

When you have a file that complies with the above rules, choose:
File > New Ticker List, then File > Import Ticker List..., then click Import.

BragIt
Haeffnersvägen 18
SE-129 38 Hägersten
SWEDEN

WWW: http://stockxloader.com
E-mail: inf @ stockxloader.com

http://stockxloader.com
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